4 posts / 0 new
Last post
#1 May 13, 2019
dumani15
Offline
Last seen: 1 day 12 hours ago
Joined: 2019-05-13 07:09

Error, lib fail, undefined device and floating

1)Even thought i edit sspice simulatin and add UCC28710. lib file it still give errors and i dont know why 

2) I tried to do a flyback transformer with primary, secondary and auxiliary with L1, L2,L3 just like the youtube videos do 

3) I dont know why the nodes are floating

My trial finished in 5 days so please help me for my graduation project

*Libraries: 
* Profile Libraries :
* Local Libraries :
.LIB "C:/Users/Ilgaz/Desktop/BTP RAPOR/ucc28710_pspice_trans/ucc28710.lib" 
* From [PSPICE NETLIST] section of C:\Users\Ilgaz\AppData\Roaming\SPB_Data\cdssetup\OrCAD_PSpice\17.2.0\PSpice.ini file:
.lib "nom.lib" 

*Analysis directives: 
.TRAN  0 100ms 0 100u 
.OPTIONS ADVCONV
.PROBE64 V(alias(*)) I(alias(*)) W(alias(*)) D(alias(*)) NOISE(alias(*)) 
.INC "..\SCHEMATIC1.net" 

**** INCLUDING SCHEMATIC1.net ****
* source FLYBACK DENEME
V_V1         N00415 N00419  AC 220V
+SIN 0 220V 50 0 0 0
R_R1         N01478 N00217 63k
R_R2         N00217 GND_POWER 88k
C_C1         GND_POWER N00185  629n   
R_R3         N002460 N00345 375
R_R4         N00345 GND_POWER 0.53
R_R5         N01954 GND_POWER 2.4k
X_U2         N00415 GND_POWER N00419 N00885 2KBP005M_3N253
D_D1         N02043 N00750 MBR150RL
C_C2         GND_SIGNAL N00750  100u   
R_R6         N00750 GND_SIGNAL 1
R_R7         N00750 GND_SIGNAL 24.96
D_D2         N01478 N00185 D1N4148_1 
C_C3         GND_POWER N00885  88u   
C_C4         GND_POWER N00885  88u   
L_L2         N00885 N01260  1200uH  
L_L3         GND_SIGNAL N02043  41uH  
L_L4         GND_POWER N01478  6uH  
Kn_K1         L_L2 L_L3 
+ L_L1    0.99 ETD29_3C90
R_R8         N00885 N02711 147k
C_C5         N02711 N00885 0.5n
D_D3         N01260 N02711 MBRS190T3 
X_U3         N002460 N00217 N01954 N00583 N00185 GND_POWER N00885 UCC28710 
X_M1         N00583 N00345 N01260 BUZ-358

**** RESUMING FLYBACK1.cir ****
.END

INFO(ORPSIM-15423): Unable to find index file ucc28710.ind for library file ucc28710.lib.

INFO(ORPSIM-15422): Making new index file ucc28710.ind for library file ucc28710.lib.

Index has 81 entries from 1 file(s).

ERROR(ORPSIM-15090):  device L_L1 is undefined

ERROR(ORPSIM-15090):  device L_L1 is undefined

ERROR(ORPSIM-15142): Node N02043 is floating

ERROR(ORPSIM-15142): Node N00750 is floating

ERROR(ORPSIM-15142): Node GND_SIGNAL is floating

Mon, 2019-05-13 10:34
RobertoGb
RobertoGb's picture
Offline
Last seen: 4 days 13 hours ago
Joined: 2016-05-24 03:10

Hello,

First of all, your GND_SIGNAL symbol must be replaced for a "0" ground symbol. Only this can be used in PSpice.

I do not see any L1 in your circuit...I think you have to delete L1 value inside of the magnetic kernel K1.

Try with this and let see if you still get any error now.

Regards

Tue, 2019-05-14 13:41 (Reply to #2)
dumani15
Offline
Last seen: 1 day 12 hours ago
Joined: 2019-05-13 07:09

Thank you. It was very helpfull advice. But now i have another problem that i could not figure out why. In the second and auxiliary side of circuit there is no voltage. I coupled them but it seems it did not work. 

In the K (K1) i wrote for 

L1  = L2

L2 = L3

L3 = L4

Is anything i did missing or uncomplete?

Wed, 2019-05-15 10:12
retiredEE
Offline
Last seen: 4 days 15 hours ago
Joined: 2018-03-21 12:19

When you include a model name (ETD29_3C90) in the coupling device K the inductance values become "number of turns".  This could be your problem since those values are such small numbers.  They should be integers.  See your PSpice Reference guide for further information.

Download PSpice Lite and try it for free! Get PSpice Lite
Cadence