Back to Forums
5 posts / 0 new
Last post
#1 Oct 16, 2020
waulu13
Offline
Last seen: 23 hours 38 min ago
Joined: 2020-10-16 06:20

Texas PSpice models

Hello,

 

I imported a Texas spice model and when I try to simulate the circuit I receive the message,

"ERROR(ORPSIM-16583): Detected an imported model containing transistors or diodes. For such models, PSpice for TI supports a minimum of one and maximum of three traces. Reduce the number of traces and simulate again."

Is this expected? I thought for Texas model it would be fine.

Beside that, I get this message for the imported model, INA253A3,

"

c:\path\library\ina253a3.lib.X_U1.Dideal is unsigned.
c:\path\library\ina253a3.lib.X_U1.X_U37.DVN is unsigned.

"

I don't undertand this message, should I do something?

 

Best regards,

Manuel Sobral

Sat, 2020-10-17 13:05
retiredEE
Offline
Last seen: 1 day 17 hours ago
Joined: 2018-03-21 12:19

From the PSpice for TI datasheet:

Model Import

"There is no size and/or simulation complexity limitation if the design contains only TI Library
and/or Cadence Behavioral models. There will also be no limitation on the number of signals
being probed by the user when the design has all components from the inbuilt PSpice library
including TI components.

We understand that some designs may require other 3rd party components to be added to the
design. There is no limitation of how many 3rd party models can be imported into the design.
However, if 3rd party models are imported, a user will be able to plot a maximum of 3 signals at a
time of their choice when any 3rd party model is imported from web."

The INA253 hasn't been added to the TI PSpice library yet so it's considered a 3rd party import.  Add 1 to 3 markers on your schematic to limit the number of signals collected during simulation.  I've downloaded that model and successfully simulated the included circuit using this technique.  I'm puzzled by your other messages; I didn't get them at all.

Mon, 2020-10-19 04:36 (Reply to #2)
waulu13
Offline
Last seen: 23 hours 38 min ago
Joined: 2020-10-16 06:20

Thank you retiredEE.

Besides these messages, I can simulate also. For now, I leave it as it is.

 

I will ask you another favor, could you try to simulate the example that comes with the model, "slom492\ina253a3.opj"? That one gives me an error and I really can't simulate.

The output is,

 

"

--------------- INFO(ORPROBE-3209): Simulation Profile:  SCHEMATIC1-TRANSIENT ---------------
INFO(ORPROBE-3183): Simulation running...
** Profile: "SCHEMATIC1-TRANSIENT"  [ C:\Users\Manuel.DE-CASTRO-SOB\Downloads\slom492\ina253a3-pspicefiles\schematic1\transient.sim
Reading and checking circuit
Circuit read in and checked, no errors
ERROR(ORPSIM-16592): Detected an imported model containing transistors or diodes
Run aborted
  Total job time (using Solver 1)   =         .05

INFO(ORPROBE-3188): Simulation aborted


"

The link for the model is,

 

https://www.ti.com/lit/zip/slom492

 

Best regards,

 

Mon, 2020-10-19 11:42
retiredEE
Offline
Last seen: 1 day 17 hours ago
Joined: 2018-03-21 12:19

I had no problem simulating the example that comes with the model, "slom492\ina253a3.opj".  Make sure you add markers to the schematic and set the Probe Window to show "All Markers on open schematics".

Tue, 2020-10-20 04:13
waulu13
Offline
Last seen: 23 hours 38 min ago
Joined: 2020-10-16 06:20

You are right retiredEE. I didn't realize I had to add probe, I thought I could simulate and after that add a trace.

 

Thank you.

Download PSpice and try it for free! Download Free Trial
Cadence