Back to Forums
7 posts / 0 new
Last post
#1 Feb 2, 2017
RGouret
Offline
Last seen: 3 years 6 months ago
Joined: 2017-02-02 12:20

Variable resistor ZX

Hello

I have to modelize a tramway line. To do that I have a current source define by segment (part "IPWL") and I have to study the impact of this load on the feeder voltage.

The only problem I have is that resistors of the line are not linear, they are moving in an non linear way with time. 

So I add the librairy "anl_misc.olb" to have the part "ZX" to have the behaviour of the resistor I want.

When I try to simulate I have the error message "ERROR(ORPSIM-15108): Subcircuit ZX used by X_X1 is undefined".

I don't understand how to fix this problem, I try to define the parameters in the part "PARAMETERS" of the "special" librairy but it still doesn't work.

Can you help me with this ?

Thank you 

Sincerely 

Raphael Gouret

 

Fri, 2017-02-03 03:03
RobertoGb
RobertoGb's picture
Offline
Last seen: 2 years 2 months ago
Joined: 2016-05-24 03:10

Hi,

Such error means that the component you are using has not any PSpice Model attached. Could you tell me please which version you are using? Could you tell me, which libraries you have attached in the Simulation Profile --> Configuration Files --> Library? Are you using a Demo Version or a licensed one?

Roberto

Fri, 2017-02-03 03:47 (Reply to #2)
RGouret
Offline
Last seen: 3 years 6 months ago
Joined: 2017-02-02 12:20

Hi

I have load the free version of OrCad : 16.6_OrCAD_Lite_Capture&PSpice_Products . 

I think it Pspice students 9.2.

I have press the place part icone and add the librairy anl_misc.olb 

In "Simulation_Configuration Files_Library_Library Path" I have browsed this " "C:\OrCAD\OrCAD_16.6_Lite\tools\PSpice\Library";"C:\OrCAD\OrCAD_16.6_Lite\tools\capture\library\pspice" ".

Is it enough?

I have try again with Vpulse (V1 0.1 ; V2 1; TD 0,5 m ; TF 1u; TR 1u; PW 0.5m ; PER 4m )  in pin1; ground in pin2; a resistor 50 ohms between pin3 and the ground ; a VDC 1V in pin4 and the ground in pin5. And now I have the error message "ERROR(ORPSIM-16152): Invalid number" . 

Should I give a value to "ZX"?

Thank you for you help

Fri, 2017-02-03 03:58
RobertoGb
RobertoGb's picture
Offline
Last seen: 2 years 2 months ago
Joined: 2016-05-24 03:10

Hi,

It should be enough, but if I remember well, in the Version 16.6 Cadence removed in the Student Version all the available libraries. That is why I need to know not only the paths you have added, but also if you can see nomd.lib or nom.lib. If you are seeing the first one, you should change many things manually. My recommendation is that you install the last Student Version (17.2) which works perfectly. 

 

In relation to the ZX component, see an example below:

 

I hope it helps.

 

Fri, 2017-02-03 04:06 (Reply to #4)
RGouret
Offline
Last seen: 3 years 6 months ago
Joined: 2017-02-02 12:20

Hi

I have nomd.lib in the configuration files.

So I have to load the version 17.2? 

Can you send me a link to download this?

Thank you

Fri, 2017-02-03 04:10
RobertoGb
RobertoGb's picture
Offline
Last seen: 2 years 2 months ago
Joined: 2016-05-24 03:10

Hi,

I is not necessary to download 17.2 in order to simulate what you want, but in the 16.6 you have to do a workaround. That is why, it makes sense to uninstall 16.6 and install 17.2 :)

Find below the link where you can download it:

http://www.orcad.com/buy/try-orcad-for-free 

Regards

Fri, 2017-02-03 04:13 (Reply to #6)
RGouret
Offline
Last seen: 3 years 6 months ago
Joined: 2017-02-02 12:20

Ok

Thank you a lot for your help.

Download PSpice and try it for free! Download Free Trial
Cadence